Ask the Expert

Unable to connect to server with Oracle8i

I've just installed Oracle8i in my system. My OS is Windows XP. I was able to connect to the server and work yesterday, but today I'm not able to connect to the server. I'm getting ORA-01034, the "Oracle not available" error. I checked my OracleServiceSID; its status is starting. It's not getting started even after starting it manually. I'm a beginner, please help me. Thanks in advance.

    Requires Free Membership to View

The most common cause of this problem is when the STARTMODE of the service is set to manual. When the service for the database is created with the oradim utility, you have the option to specify a STARTMODE as either AUTO or MANUAL. It's possible that the service was created with the STARTMODE as MANUAL, in which case your database would not start up automatically when the server reboots or starts up. To change this, you can re-create the service with the oradim utility (after shutting down your database). You can use the command:
oradim –edit –sid  –startmode auto
It is also possible that the service is starting up but not the database. In this case, it is possible that the STARTTYPE was set to SRVC rather than INST. This would start the Windows service but not the database itself. This, too, can be modified with the oradim utility.

This was first published in October 2005

There are Comments. Add yours.

 
TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
Sort by: OldestNewest

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to: