Ask the Expert

ORA-12638: Credential retrieval failed

I'm getting the infamous "ORA-12638: Credential retrieval failed" error message when trying to connect to Oracle 10g Express through the adaptor provided in the .Net Oracle Developer Tools. I'm running Windows XP Pro under a domain account.

I've installed 10g Express under a local account with Admin privileges. I've also changed "SQLNET.AUTHENTICATION_SERVICES= (NTS)" to "SQLNET.AUTHENTICATION_SERVICES= (NONE)."

Everything works perfectly under the local account. Unfortunately, when I log in under my domain account I then get the ORA-12638 error when attempting to connect.

I've attempted to run OracleServiceXE and OracleXETNSListener under my local account, but that doesn't seem to work.

Has someone run into this issue before? Does anyone know of a workaround I can use? Thanks!

    Requires Free Membership to View

Try setting SQLNET.AUTHENTICATION_SERVICES= (BEQ,NONE) in your SQLNET.ORA configuration file. Otherwise, it has been reported that waiting a signficant time for the credentials to expire can fix the problem. If it works the next day, then you know the NT credentials expired (as far as Oracle is concerned) and life is back to normal.

If these suggestions do not work, then you'll have to file a Service Request with Oracle Support to get the issue fixed.

This was first published in November 2006

There are Comments. Add yours.

 
TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
Sort by: OldestNewest

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to: