Q

Makefile errors during upgrade

I have been trying to upgrade Oracle version 9.2.0.1 to 9.2.0.4. But I am facing some errors while upgrading. I tried to relink the makefiles manually but that also didn't solve the issue.

I have been trying to upgrade Oracle version 9.2.0.1 to 9.2.0.4. But I am facing some errors while upgrading. Firstly, I upgraded the Oracle Universal Installer from 2.2.0.12.0 to 2.2.0.18.0, needed for patchset 9.2.0.4 installation. Then when I proceed with patchset installation, the following errors occur:
Error in  invoking target link of makefile
/app/oracle/9.2/precomp/lib/ins_precomp.mk
Error in  invoking target link of makefile
/app/oracle/9.2/network/lib/ins_net_server.mk
Error in  invoking target link of makefile
/app/oracle/9.2/network/lib/ins_net_client.mk
Error in  invoking target link of makefile
/app/oracle/9.2/sqlplus/lib/ins_sqlplus.mk
and the same errors for linking other makefiles.

I tried to relink the makefiles manually but that also didn't solve the issue. Please let me know the solution for this?

Ensure that you have sufficient system resources as indicated in the patchset readme.txt document. These types of errors are usually due to insufficient swap space.
This was first published in December 2006

Dig deeper on Oracle database installation, upgrades and patches

Pro+

Features

Enjoy the benefits of Pro+ membership, learn more and join.

Have a question for an expert?

Please add a title for your question

Get answers from a TechTarget expert on whatever's puzzling you.

You will be able to add details on the next page.

0 comments

Oldest 

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to:

-ADS BY GOOGLE

SearchDataManagement

SearchBusinessAnalytics

SearchSAP

SearchSQLServer

TheServerSide

SearchDataCenter

SearchContentManagement

SearchFinancialApplications

Close