Ask the Expert

"Invalid username/password" error

I have installed Oracle 9.2 on Windows 2003 Server. I created a single database, and I am having a problem with the 'SYSTEM' and 'SYS' user password. At the time of installation I changed the password and then tried to connect with SQL. It worked fine but after a while it didn't and I got the following error:
ORA-01017: invalid username/password; logon denied
While in EMC when I try to connect as sysdba I do connect. Then I usually change the password so both users connect, but again after some time they don't and I have the same problem. Other users connect successfully. Please help.

    Requires Free Membership to View

Oracle does not just change the password on its own. If you were able to connect successfully with a userid/password combination and later that same userid/password combination receives the ORA-1017 error, then that combination is no longer correct. This means that someone has changed the password on you.

This was first published in November 2005

There are Comments. Add yours.

 
TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
Sort by: OldestNewest

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to: